[–] B3bomber 0 points 2 points (+2|-0) ago 

Site requires JS enabled (nope.).

[–] polygeek ago  (edited ago)

Because niggers?